• 1
  • 2
  • 3
  • 4
  • 5
  • 6

1044 火星数字 (20分)

1044 火星数字 (20分)

火星人是以 13 进制计数的:

地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

先贴出自己的代码,太渣了。。

#include <iostream>
#include <algorithm>
#include<cmath>
#include<cstring>
using namespace std;
char huo[12][4] = { "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
char huogao[12][4] = { "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
int tohuo(char zi[]) {
	int shu;
	sscanf(zi, "%d", &shu);
	int b2 = shu / 13;
	int b1;
	b1 = shu % 13;
	if (b2 == 0 && b1 == 0) {
		cout << "tret" << endl;
		return 0;
	}
	if (b2 == 0 && b1 != 0) {
		cout << huo[b1 - 1] << endl;
		return 0;
	}
	if (b2 != 0 && b1 == 0) {
		cout << huogao[b2 - 1] << endl;
		return 0;
	}
	if (b2 != 0 && b1 != 0) {
		cout << huogao[b2 - 1] << " " << huo[b1 - 1] << endl;
		return  0;
	}
}
int todi(char n[]) {
	int m = -1, nn = -1;
	if (n == "tret") {
		cout << 0 << endl;
		return 0;
	}
	for (int i = 0; i < 12; i++) {
		if (n[0] == huogao[i][0] && n[1] == huogao[i][1] && n[2] == huogao[i][2]) {
			m = i;
		}
		if (n[0] == huo[i][0] && n[1] == huo[i][1] && n[2] == huo[i][2]) {
			nn = i;
		}
	}
	if (m < 0) {
		cout << nn + 1 << endl;
		return 0;
	}
	else {
		nn = -1;
		for (int i = 0; i < 12; i++) {
			if (n[4] == huo[i][0] && n[5] == huo[i][1] && n[6] == huo[i][2]) {
				nn = i;
			}
		}
		if (nn >= 0) {
			cout << (m + 1) * 13 + nn + 1 << endl;
		}
		else {
			cout << (m + 1) * 13 << endl;
		}
		return 0;
	}
}
int main() {
	int n;	char zi[20];
	cin >> n;
	getchar();
	for (int i = 0; i < n; i++) {
		memset(zi, 0, 10);
		cin.getline(zi, 10);
		if (zi[0] >= '0'&&zi[0] <= '9') {
			tohuo(zi);
		}
		else {
			todi(zi);
		}
	}
	return 0;
}

再是柳神的代码,没有对比没有伤害。。

#include <iostream>
#include <string>
using namespace std;
string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {"####", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string s;
int len;
void func1(int t) {
    if (t / 13) cout << b[t / 13];
    if ((t / 13) && (t % 13)) cout << " ";
    if (t % 13 || t == 0) cout << a[t % 13];
}
void func2() {
    int t1 = 0, t2 = 0;
    string s1 = s.substr(0, 3), s2;
    if (len > 4) s2 = s.substr(4, 3);
    for (int j = 1; j <= 12; j++) {
        if (s1 == a[j] || s2 == a[j]) t2 = j;
        if (s1 == b[j]) t1 = j;
    }
    cout << t1 * 13 + t2;
}
int main() {
    int n;
    cin >> n;
    getchar();//吸收回车,不然getline()会读取回车
    for (int i = 0; i < n; i++) {
        getline(cin, s);//学习一下
        len = s.length();
        if (s[0] >= '0' && s[0] <= '9')
            func1(stoi(s));
        else
            func2();
        cout << endl;
    }
    return 0;
}

 

点赞

发表评论

电子邮件地址不会被公开。必填项已用 * 标注